Wednesday, March 21, 2007

subversion 1.4.3 on ubuntu Edgy amd64

Just went through a few dramas tonight to upgrade svn on my system from the old 1.3.2 version that is in the ubuntu repos to the latest 1.4.3.

I found this howto which gets you almost all the way there. Unfortunately amd64 uses will get a link error complaining that libneon.a needs to be compiled with the fPIC flag. This is easily fixed by changing the following line in neon/src/Makefile (line 28) after the configure step from this
CFLAGS = -g -O2
to
CFLAGS = -g -O2 -fPIC

then you make and install as per the howto.

HTH!

Labels:

2 Comments:

Blogger hyperwired said...

Thanks for this. Helped me compile svn 1.4.6 on my web hosting's server.

1:59 am  
Blogger wop said...

thanks dude, helps with 1.5 as well...

tricky libraries

9:06 am  

Post a Comment

<< Home